2D Tools Category

Table of Contents

  1. Contents of 2D Tools

2D Tools

Scaling

Scaling Blocks in LD Assistant & AutoCAD
Working with Metric and English Blocks in AutoCAD or LD Assistant.
If you use blocks that were drawn in METRIC, you will need to scale them.
With LD Assistant and AutoCAD, the program can do the work for you.
1

 

The next time you have to use Metric blocks try this.

Perform a right mouse click on the drawing area. This will bring up a menu. At the bottom of the list click on options, then click on the User Preferences tab.

Looking at the picture to the left, you will see Highlighted in red information about the Block Navigator/design center.

2

By clicking on the drop down arrow, the incoming blocks units can be changed to Millimeters. Now, when you drag a Metric block into the drawing, LD Assistant/AutoCAD will scale the blocks from metric to English for you.

Remember to change this setting back to INCHES after you have finished working with the Metric blocks.

 

Rufus

Rotation using reference

Rotation using reference
1

 

1

From the Modify tool bar ....click on the rotate 1 button.

 

1

 

The cursor turns into a square .. now, click on the outline of the (B) box and right mouse click for enter, .. it highlights with a dotted line.

Place the cursor at location (1) of the (B) box and click the left mouse button .... next type the letter R and push the enter key.

Once again, move the mouse to location (1) and click the left mouse button.

1

Move the cursor to location (2) on box (B) and click the mouse.

1

 

Now, move the mouse to the new location and click the left mouse button.
1

 

 

1

For more on rotation, check out the LDA help (F1).

Rufus

Aligning objects using ALIGN tool

 
 
Aligning objects using ALIGN tool
1
 

1
1
 


1

From the Modify drop-down menu, and down to .. 3D Operation, then the fly-out .. Click on Align. The cursor turns into a square. Now, click on the truss block (B) and then right mouse click for enter..
 

1

Move the cursor to location (1) on truss (B) and click the mouse.
 

1

Next, place the cursor to location (2) truss (A) and click the mouse.
 

1

 

Right mouse click for enter......

1

 
1
From the Modify drop-down menu, and down to .. 3D Operation, then the fly-out .. Click on Align. The cursor turns to square.

1

Now, click on the truss block (B) and then right mouse click for enter.. Now, click the mouse at location (1) on truss (B) ... Next, click the mouse at location (2) on truss (A)
 

1

Now, click the mouse at location (3) on truss (B) and click the mouse at location (4) on truss (A)Right mouse click for enter ....
 

1

 
Rufus

Aligning objects part 2

Aligning objects using ALIGN tool

1

 

1

 

1

 From the Modify drop-down menu, and down to .. 3D Operation, then the fly-out .. Click on Align. The cursor turns to square. From the Modify drop-down menu, and down to .. 3D Operation, then the fly-out .. Click on Align. The cursor turns to square.

 1

 Now, click on the truss block (B) and then right mouse click for enter.. Now, click the mouse at location (1) on truss (B) ... Next, click the mouse at location (2) on truss (A)

1

Now, click the mouse at location (3) on truss (B) and click the mouse at location (4) on truss (A)Right mouse click for enter ....

1

 

Rufus

Creating a Magic Sheet

Issue
You want to create a Magic Sheet

Solution
Under the drop-down menu, click on LD Options. That will bring up the dialog below. Then click on Edit ldschedlist.txt button.

1

 

This opens the ld schedule list for editing.
At the end of the line... place your cursor and type the line that is highlighted below.

1
If you copy the first line of data at the top (lights Schedule), and paste it at the bottom this might make it easier if you are not acquainted with comma delimited files. Then all you have to do is to delete the data field you do not want to see in the Schedule .
Once you have added the data, close and save the file... This will bring you back to the LD Options... click OK
Next, under the Lighting drop-down click on Schedule.. At the bottom of the list you will see your Magic Sheet... Click on it and click the OK button.
1

As the Magic Sheet opens you see the Target listed under Purpose.

1


NOTE: We are using the Purpose data field to retrieve the necessary information !
Rufus

Working with a wheel Mouse

Working with AutoCAD or LD Assistant wheel mouse buttons

In this news letter we will look at increasing productivity with the use of a wheel mouse.You can choose options from menus and toolbars by clicking them with your mouse. You also can use the mouse to draw or to select objects on the screen. With a two-button mouse, the left button is the pick button used to specify points on the screen.

The right button either displays a shortcut menu or is equivalent to pressing ENTER, depending on your pointer location and the right-click settings.

Pressing SHIFT and right-clicking, displays the Object Snap shortcut menu. With a three-button mouse, the middle button either activates real-time panning or if you rotate the wheel the drawing will ZOOM in or out at the point the cursor is placed on the drawing.

It's like the CAD program was created around the mouse!
The illustration below shows a number of different examples.

1

1

The wheel on the mouse is used to ZOOM the drawing in and out. This feature alone can increase productivity by tenfold. By pushing down on the wheel the cursor will turn into a pan hand.

 

1

 

A time delay mouse button!

The one feature that I like best is the time delay in the right mouse button. When you have one or more objects selected, you can deselect the objects by holding down the right mouse button for little over a second. If you hold down the right mouse button for less than a second the menu below will appear.

1

When you are using 3D Orbit tool a right mouse click will bring up the menu to the right.

To exit 3D Orbit perform a right mouse click and click on EXIT.
1
If you are using a drawing tool like polyline, a right mouse click will bring up a menu that allows you to change the tools functionality while drawing.
1
 
By selecting a lighting fixture and performing right mouse click. You have access to the key features without having to go up to the pulldown menus.
1
Placing your cursor over an icon and performing a right mouse click will display a menu where you can select which tool palette you want displayed on the screen.
1

Rufus

Modifying Blocks (Fixtures) using

Modifying Blocks (Fixtures) using:
Refedit to rotate the 3D part of a block

1

Place a block on the drawing.

NOTE: To open any palette, place your cursor over any icon along the top and click the right mouse button ... this will open a fly-out menu to select palettes from.

1

From the LD view palette

1

click on the Front view button .

1

From the Refedit palette click on the Edit Block button then click on the block in the drawing..

1

When this dialog box opens, click on the OK button. Now, place the cursor in the drawing. Holding down on the left mouse button draw a square around the block. (This select all the parts for editing.) Next, right mouse click for enter .. or push the enter key.

 1

 From the tool palette, click on the rotate button.

 1

 

Holding down on the left mouse button draw a square around the block (This select all the parts for rotating.) and rotate the fixture 180 deg..

1

 

1

Now click on the Save back changes to reference.

1

At this dialog box click OK ..... and the job is done.

 

Rufus

Understanding Group

Understanding Group

To start the group LD Assistant and AutoCAD are not like group in other CAD progrm, with the LD group if you turn it off you can remove an object in the group and when you trun the group back on... they are all grouped togather. Moerover you can move an object in a group without haveing to ungroup. With that said lets start.

The Group command does not appear in the toolbars or menus, nor does it have a keyboard shortcut. While group as many more fontions, we will only go ove the baices.

Start the command, by typing group and hit the enter key.

You are now presented with the dialog box shown in figure 1.

1

Figure 1.
Object Grouping dialog box.

Type a name in the Group Name box. If you want, you can click on the Description box and enter an explanatory note. (Tables, Truss, Fixtures ... ect;)

Now pick the New button. The dialog box collapses and now click on all the objects that you want in that group. After you have selected all the objects, hit the enter button and the dialog box reappears, now the the upper portion displays your group name.

1
Figure 2.
Click an object to grip-edit the entire group.

Now when you click and drag a blue grip, that one object moves independently within the group. When you press Esc to clear the grips, the entire group becomes selectable again.

The Group dialog box offers several other useful functions. For example, have you lost track of a group's name? No problem. Pick Find Name. The dialog box collapses and you're invited to select an object. If you select one that belongs to a group, a box pops up listing the group name or names. An object can belong to more than one group.

If you pick a group name from the upper window of the Group dialog box, another inquiry function becomes available, as do several Change Group functions at the bottom of the dialog box. Figure 3 shows an example of this.

1

Figure 3.
By select a group name you activate the Change Group buttons.

The function of most buttons is obvious from their labels, but one or two have a bit of a twist.

Now that you have seen the basic mechanism for creating, using, and editing groups, here are a few other significant points: A group can contain any type of AutoCAD object, including lines, circles, arcs, polylines, text, dimensions, block insertions, and other groups.

 

Rufus

Creating a LD Assistant Block

LD Assistant's Create a Block

1) Create the 2D part of the fixture.

It is important that you move the 2D part of the fixture at 0,0,0.

If you do not when you go to insert the block into your drawing the block WILL NOT show up at the end of your cursor.

2) Next you will need to make the 3D part of the fixture.

NOTE: The barrel of the fixture is pointed toward the top of the screen.

 

Once you have created the 2D and 3D part of the fixture you will need to create two (2) layers.

1) Create a layer called      2d_FIXTURE

2) Create a layer called      3d_FIXTURE

 

Now move the 2d fixture part to the 2d_FIXTURE layer.

Next move the 3d fixture part to the 3d_FIXTURE layer.

 

The reason we do this so when you are in the top view you see the 2d and when you are in a ed view you only see the 3d part of the fixture.

NOTE:
Be sure to have both the 2d_FIXTURE and the 3d_FIXTURE layers ON.

Make sure the 2d Yoke part is at 0,0,

 

Now move the 3d part over the 2d part.

 

Looking on the Draw pallet click on make block or... (left) under the menu Draw and click on Make.

 

When the dialog above opens:
1) Type in the name of the block

2) Click on Pick Point (2)... the dialog will close now click where the C-Clamp bolt would be.
    Once you click the Block Definition dialog opens again.

3) Now click on Select objects (3), the dialog will closes, now Select all the object by drawing a rectangle around the 2d and 3d parts. Once all parts are select do a right mouse click. The Block Definition dialog will open again... now click the OK button and the dialog closes.

You have created a block but for to show up and be tracked in the schedules you will need to turn the block into an LD Assistant object.

To turn the block you just made into a block that LD Assistant will recognize.

Under the menu Lighting look for Utilities and at the fly-out click on Define new LD object...

At the prompt click Next.

If you created your fixture with barrel pointing toward the top of the screen you can click NEXT at this prompt.

At this prompt, click on the name of the block (Test Fixture) and click on Add attributes button.

After the attributes are added click the Next button.

NOTE:
The drop down at the top right is user to add attributes to Truss, sound, point light etc:

 

This prompt, is asking where does the light come out of the fixture.

Click on the front of the fixture and a little green circle appears.

Click the Next button.

 

At this prompt click on the Update block references button then click on the Close button.

 

**** When the LD Assistant Wizard closes               
DELEATE the block from the drawing area
***

 

Now that you have delete the block from the drawing you will want to re-insert it.

Look for the menu Insert and click on Block...

 

When the dialog open, select the Test Fixture and click the OK button.

When the dialog closes click when you would like to insert the Test Fixture.

 

Now use the LD Assistant Views to see the fixture in 2d and 3d.

2D view

 

3D View

 

3D isometric View

Rufus

Change Block Text, Size and Placement

Change Block Text, Size and Placement

We start by turning on all the attributes.

Next we select the block and perform a right mouse click, click on Edit Block In-Place

 

When this dialog open click the OK button.

The Refedit menu that opened.

 

Once you see the block you can move, resize, change the color and placement of the text.

 

Once you have made your modifications CLICK on Save Reference Edits.

 

*** To see the changes on the block,
         you will have to delete it from the drawing and re-insert it. ***

 

Look for the menu Insert and click on block.

At this dialog select the name of the block and click OK.

When the dialog closes click where you want the block to be inserted.

 

This modification is only good for the file you have open and does NOT modify the source block.

If you would like to customize a set of blocks to use all the time, you will need to modified each block one at it's source file. Contact tech support at LD Assistant and we will be glad to help.

 

Rufus

Powered by KnowledgeBuilder